安装更新时发生错误:0x80240037的解决办法

2019年4月1日23:22:47 发表评论

今天在重新安装Vagrant,因为之前的版本有些问题,所以就下了最新版本的安装,装了并增加了 vagrant box之后,输入vagrant up命令启动虚拟机时, 报错提示:powershell的版本过低,要求powershell的版本是3,,现在的版本是2,于是开始了漫长的升级powershell 3.0的过程,因为在安装windows更新的时候,一直装不上,提示安装更新时发生错误:0x80240037,尝试了:1)重装Framework 4.0、4.5、 4.7; 2)关掉了防火墙(这个操作显得有点愚蠢,是病急乱投医了);3)打开Windows的自动更新功能,把Windows Update, Windows Installer等服务启动了,始终没解决报错的问题,最终找到了下面这篇博客,换这种方法一安装就成功了,不得不感叹Windows的水也挺深的,我—一位十多年的微软系统用户了,连安装个更新都这么费劲,完全不得其法。。特别鸣谢这位博主并转发了这篇博客分享给大家! 
郑重声明:本文属于转载,原链接地址为:https://blog.csdn.net/m0_37397536/article/details/79271709

安装ie插件或者微软的一些其他程序等报错0x80240037, 
解决办法:

下面我将以ie的插件IE11-Windows6.1-KB3008923-x64.msu安装为例:

1、把IE11-Windows6.1-KB3008923-x64.msu的后缀名msu改为cab,然后解压,注意解压到一个新的文件夹中,不要在本文件夹中解压(例如:我的解压在cab文件夹中);

然后运行cmd(win键+R键) 
输入:dism /online /add-package /packagepath:”X:\路径\文件名.cab

(例如:我应该输入:dism /online /add-package /packagepath:”C:\ie\cab\IE11-Windows6.1-KB3008923-x64.cab”) 
然后控制台就会出现安装进程了,很快就安装成功了!

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: